Textfont ändert sich bei Anzeige auf iPhone

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Textfont ändert sich bei Anzeige auf iPhone

    Guten Tag zusammen

    Ich habe soeben meine Test-Webseite hochgeladen (germ.ch). Wenn ich das am PC mit Google Chrome oder IE betrachte erscheinen die Textfonts wie eingestellt (Segoe UI Light). Wenn ich das mit Safari auf dem iPhone anschaue erscheinen die Texte ähnlich wie Times New Roman oder so. Wie kann ich das so einstellen, dass das auch auf dem Mobile korrekt erscheint? ?(

    Zudem erscheint die angegebene Telefonnummer auf dem iPhone als Link (blau und unterstrichen). Wie kann das korrekt dargestellt werden ohne Link?

    Herzlichen Dank für eure Tips.

    Grüsse
    Roger

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von rogerio ()

  • Am Computer hast du die Fonts installiert, deshalb siehst du sie auch korrekt! Auf anderen Geräten wo diese Fonts nicht installiert sind, werden Sie mit einem Standard Fonts ersetzt. Du musst diesen Font als "WEbfont" einbinden. Das kannst du gleich beim Start des Programms unter "Einstellungen" ! Dazu benötigst du 4 verschiedene Dateien die du im Internet sicherlich finden kannst. Wenn es ein Google Font ist dann einfach die URL eintragen. Anleitungen sind dann bei Google !
    Wissen ist MACHT ! Nichts zu Wissen macht nichts !
    Wissen ist MACHT ...ohne es zu wissen !
  • hi andy

    besten dank. ich konnte die dateien im internet erzeugen lassen über den font squirrel und diese 4 dateien auch in den einstellungen einbinden. leider werden aber die texte aber auf dem iphone trotzdem nicht korrekt angezeigt. woran kann das denn liegen? ich hänge dir mal die projektdatei mit an zur nachvollziehbarkeit. ist auch unter germ.ch zu sehen.

    grüsse & danke für erneute tips :)
    Dateien
  • KAnn ich leider nicht testen, da ich kein Iphone habe, aber in den Browsern und am Android Handy/Tablett wird es korrekt angezeigt. In der CSS ist es auch korrekt enthalten.
    Vielleicht hat Apple irgendeine Sperre gegen spezielle Webfonts.
    Wissen ist MACHT ! Nichts zu Wissen macht nichts !
    Wissen ist MACHT ...ohne es zu wissen !
  • danke. hab eben bemerkt dass der "fette" font Swiss721 BlkCn BT funktioniert (auch in den beiden Kopfzeilen) wenn ich bei einem Teil des langen Text im Rahmen die gleiche Schriftart Swiss721 BlkCn BT auswähle. Die beiden Kopfzeilen sind manuell in html geschrieben, wenn nun also sonst nirgends diese Schriftart ausgewählt wird klappt das nicht in den beiden Kopfzeilen. Es liegt also nicht an Safari sondern irgendwie an der Einbindung der Schriften. Muss ich nun die Schriftart irgenwie manuell noch im html code der kopfzeile dazufügen?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von rogerio ()