Parse error

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hallo zusammen,
    habe auf meiner Website mehrere geschützte Seiten angelegt. In der Vorschau von WS X5 sind sie ohne Probleme zu sehen. In der hochgeladenen Website erscheint dagegen die Fehlermeldung:
    Parse error: "syntax error, unexpected ''<tr><td id="imEmailHeader" st' (T_ENCAPSED_AND_WHITESPACE) in /www/htdocs/w0186b37/ffw-jesendorf.de/res/x5settings.php on line 119" und die Seite wird nicht dargestellt.
    Habe bis jetzt schon über das X5 Helpcenter verschiedene Lösungsvorschläge bekommen, aber keiner hat geholfen.
    URL ist: ffw-jesendorf.de
    Bitte dringend um Hilfe
  • Lieber mit vollem Mund reden - als mit leerem Hirn denken :saint:

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von pcssa ()

  • Auch bei mir kommt diese Fehlermeldung…
    Dateien
    Lg.
    Thabo-Umasai
    -----------------------------------------------------------------------------------------------------------
    "Was du heute kannst besorgen, das verschiebe nicht auf Morgen...."
    ;)
  • Also die Sache mit Zertifikat und Https ist erledigt. Danke an alle dafür. Leider bleibt aber immer noch das Problem mit der Fehlermeldung. Habe jetzt mal die Seite "Dienstplan" wieder freigegeben. Und sieh da, sie ist wieder sichtbar. Also vermute ich, das es doch eigentlich nur ein Programmfehler von INCO sein kann.
  • In der Vorschau werden die Seiten natürlich angezeigt mit dem Hinweis dass die geschützte Seite nur Online funktioniert. Das heisst Online müsste statt der Seite die Login Seite kommen oder einfach das Login Feld. Wenn statt dessen diese Meldung kommt, dann kann es kein PHP verarbeiten am Server.
    Die letzte Möglichkeit wäre wenn sich durch die Versionsunterschiede, Konvertierungen (von V9 auf V10 auf V11 auf V12 usw.) irgendwann mal ein Fehler eingeschlichen hätte und die gesamte Website nicht am Server gelöscht worden ist, dass es zu Überschneidungen alter und neuer PHP Code kommt.
    Ansonsten wenn aus der V16 eine neue Website auf einen leeren Server gespielt worden ist, kann es keine Fehlermeldung geben, wenn am Server PHP aktiv geschaltet worden ist.

    Wenn es trotzdem noch zu dem Fehler kommt, würde ich mal einen anderen Server versuchen der auch PHP zur Verfügung stellt und dort testen. Oder einfach ein neues Projekt erstellen mit nur einer geschützten Seite und dieses in einen Unterordner am Server spielen und testen ob dort auch der Fehler kommt.
    Wissen ist MACHT ! Nichts zu Wissen macht nichts !
    Wissen ist MACHT ...ohne es zu wissen !
  • Hallo Andy,
    folgendes dazu:

    Nach vielen vergeblichen Anfragen sowohl hier im Forum als auch bei externen Fachleuten hat tatsächlich ein sehr guter Bekannter die Lösung für mein Problem gefunden und auf dem Server das Problem korrigiert:
    In Datei /res/x5settings.php Zeile 119 fehlt das Abschließende String-Ende und Semikolon. Zeile sollte so aussehen:
    $ImMailer->header = 'GENERIERTER INHALT';
    ist aber nach generierung der Seite so:
    $ImMailer->header = 'GENERIERTER INHALT
    Scheint also doch ein Programmfehler zu sein, da nach jedem neuen Hochladen der Fehler wieder in der Website vorhanden ist.