Bilder sind trotz Tranzparenz ganzflächig sichtbar

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Bilder sind trotz Tranzparenz ganzflächig sichtbar

    Hallo,

    ich bin am Aufbau einer Vereinshomepage. Bei allen Textobjekten habe ich die Objekteigenschaft "Hintergrundfarbe" aktiviert, mit Verlauf von links nach rechts.

    Im Textbereich (zwischen den Absätzen) möchte ich Bilder/Grafiken einfügen. Diese Bilder haben alle einen einfarbigen weißen Hintergrund. Diese Hinterfrundfarbe habe ich bei den Bildern als transparent definiert.

    Wenn ich nun dies Bilder in einem Textobjekt einfüge, sehe ich leider trotzdem das rechteckige komplette Bild. Die Farbtransparenz wird nicht berücksichtigt. So zumindes ist es bei der Vorschau, online ist die Seite noch nicht.

    Im Seitenheader ist auch eine Grafik enthalten, wo die Transparenz korrekt funktioniert. Im Bereich von WSX5, wo der Header gestaltet wird, gibt es aber eine eigene Möglichkeit, die Transparenz festzulegen. Das ist also mit meinem Problem nicht zu vergleichen.

    Geht das generell nicht oder mache ich etwas falsch.

    Ich hoffe, dass man meine Frage versteht :whistling:

    Danke für alle Antworten
  • Hallo mdreiWsX5,
    Nun deine Beschreibung ist leider sehr vage, aber ich denke ich kenne Dein Problem. Du hast Deine Bilder alle als *jpg gespeichert, und hier gibt es automatisch einen weißen Rand oder Hintergrund. Zur Abhilfe schafft nur das Du diese Bilder alle mit PS öffnest und dann als *.png sicherst. Und natürlich transparentem Hintergrund. Da Du weder einen Link noch eine Bilddatei zur genaueren Kontrolle mitsendest kann Dir keiner eine genauere Ursache sagen. Aber ich denke dies wird Dein Problem sein weil sie in *.jpg sind. Also mache mal einen Screen damit man es genauer sieht. :thumbdown:
    Lg.
    Thabo-Umasai
    -----------------------------------------------------------------------------------------------------------
    "Was du heute kannst besorgen, das verschiebe nicht auf Morgen...."
    ;)
  • Hallo,

    ja das stimmt - das Bilder sind alle im jpg-Format. Ich war aber der Meinung, das ginge auch.

    Ich werde Deinen Tipp heute Abned sofort ausprobieren und das Ergebnis mitteilen. Ein Screenshot ist jetzt gearde nicht möglich, da ich nicht zuhause bin, werde den aber gerne nachliefern, sowohl Version-alt (jpg) und Version-neu (png).

    Super, die schnelle Antwort.

    Vielen Dank !!
  • Gerne und eines noch wenn Du die Bilder sicherst als *.png dann verwende in PS die Option "Für Web Speicher" Und Interlaced.
    Lg.
    Thabo-Umasai
    -----------------------------------------------------------------------------------------------------------
    "Was du heute kannst besorgen, das verschiebe nicht auf Morgen...."
    ;)
  • Hallo,

    so, ich habe Deinen Vorschlag erfolgreich umgesetzt :thumbsup:
    Anbei das Versprochene Beispielbild !!


    Ich hätte da gleich noch ne Frage.
    Achte bitte mal auf den linken Rand der Textzeilen (rechts vom Datum).
    Im Editor stehen die sauber untereinander, bei der Vorschau-Anzeige jedoch nicht.
    Bp: Letzte beiden Einträge in 2011, erster in 2010 - was kann das nun wieder sein.


    Danke und Gruß
    M.



    [img]http://www.leaah.de/images/jpg_vs_png.png[/img]
  • Da haste sicher um ein Leerzeichen zu viel darin, Kontrolliere dies mal das ist ein typischer Fehler ;)
    Lg.
    Thabo-Umasai
    -----------------------------------------------------------------------------------------------------------
    "Was du heute kannst besorgen, das verschiebe nicht auf Morgen...."
    ;)
  • Hallo,

    ja, die Leerzeichen ... wenn es nur so einfach wäre. Die sind es ganz sicher nicht, da habe ich schon x-mal kontrolliert und gezählt. Vielleicht liegt es an der Schriftart, das muss ich noch mal checken.

    Sporadisch hatte ich auch schon einen anderen komischen Effekt, der aber so nicht immer auftritt. Wird z.B. die Leerzeile zwischen der Jahreszahl-Grafik und dem Beginn der Textteilen entfernt, dann rutscht die erste Zeile der Aufzählung um etliche Spalten nach rechts. Solche sporadischen Fehler sind natürlich schwer zu lokalisieren, aber ich kann das umgehen.

    Nochmals Danke für die Hilfe :)

    Gruß

    md
  • Eine Frage hätte ich noch, machst Du es nur mit einer reinen Textdatei oder verwendest Du einen Zellenformatierung, so wie Excel? ?(
    Lg.
    Thabo-Umasai
    -----------------------------------------------------------------------------------------------------------
    "Was du heute kannst besorgen, das verschiebe nicht auf Morgen...."
    ;)
  • hallo,

    Hmmm, was meinst Du ? Formatierungen wie in EXCEL ?

    Die Zeilen sind reiner Text, danach lediglich alle markiert und als Aufzählung formatiert, damit die Punkte vorne erscheinen. Dann noch pro Zeile die Links eingefügt. Sonst nix.

    Denn Effekt, dass (wie oben beschrieben) die erste Zeile der Aufzählung nach rechts wandert (der Aufzählpunkt bleibt jedoch links stehen), hatte ich auch schon das eine oder andere mal, als ich die Jahreszahlen noch nicht als Grafk drin hatte. Ich hatte hier zuerst nur reine Textzeilen mit der Jahreszahl, die dann halt größer, fett und ohne Aufzählpunkt. Als ich damals diese Jahreszahlen im Nachhinein eingefügt habe, hatte ich den beschriebenen Effekt auch schon ein paar mal. Die verschobene Zeile lässt sich auch nicht manuell korrigiueren, da es im EDIT-Fenster ja nicht auftritt - nur bei der Vorschau ist die Verschiebung. Ich habe die Zeile dann dupliziert und die Originalzeile gelöscht, dann stimmte es wieder. Ich denke, das ist ein kleiner Bug.

    Gruß M.
  • dann versuche das ganze mal mit einer Tabellenliste denke dann kommste an Dein Ziel jedoch bei einer Linksetzung weiß ich dann auch nicht genau wie sich dies verhält. :)
    Lg.
    Thabo-Umasai
    -----------------------------------------------------------------------------------------------------------
    "Was du heute kannst besorgen, das verschiebe nicht auf Morgen...."
    ;)