Menue Icons

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Ich denke eher da liegt bei der Bildzuteilung oder so wo der Fehler, das Du es vertauscht hast mit den Menüpunkten. Solltest dieses Abteil mal kontrollieren. :thumbup: Transparent ist ja recht gut und schön, aber nicht bei solchen Sachen wie sieht dies denn dann aus wenn da auf einmal ein Button fehlt, was ist wenn dies einer nicht weiß, der findet dann nie diesen Button, also ändere dies. Guter Rat.
    Lg.
    Thabo-Umasai
    -----------------------------------------------------------------------------------------------------------
    "Was du heute kannst besorgen, das verschiebe nicht auf Morgen...."
    ;)
  • Hi Thabo-Umasai,

    du hast Recht. Habe zwischenzeitlich ein Backup hochgefahren. Der Button "Projekte" funktioniert nur bei Mauskontakt. Dies sollte jedoch nicht so sein. Er soll permanent sichtbar sein.

    Bei der vorherigen Version war er sichtbar. Jedoch sah man im Button in weißer Schrift nochmals das Wort "Projekte".
    Liebe Grüße Peter
  • braselfing schrieb:

    Ja, habe eigene Buttons. Der Header ist transparent gestellt und leer. Die Seiten mit einem vorgegebenen Bild als Hintergrund belegt. Da transparent kann der Button nicht in den Hintergrund gerutscht sein. Die Button "Home, Kontakt und Aktuell" sind ja sichtbar.

    Es kann lediglich entweder an meiner Dummheit oder an dem Menü Aufbau liegen...
    sei nicht Hard zu dir selber dumm ist keiner wahrscheinlich nur ne Kleinigkeit die übersehen wird
    Wer aufhört besser sein zu wollen, hört auf gut zu sein.
  • Dann kann ich nur sagen gib mal die ganzen nicht gebrauchten Buttons raus und dann wird es auch funktionieren. Die werden sich sicher irgendwo überschneiden.
    Ich denke ich habe Deinen Fehler gefunden Da dies ja eigenständige Buttons sind solltest Du die von WsX5 transparent machen, somit solltest Du diesen auch verlieren.
    Lg.
    Thabo-Umasai
    -----------------------------------------------------------------------------------------------------------
    "Was du heute kannst besorgen, das verschiebe nicht auf Morgen...."
    ;)
  • Habe alle überflüssigen Buttons vom Server gelöscht. Die 4 "Home, Aktuell, Produkte und Kontakt" habe ich im Ordner images gelassen. Nun ist der Button Projekte -obwohl im images ordner vorhanden- verschwunden...

    Also suchen wir morgen weiter nach einer Lösung, da ich jetzt am Laptop sitze und das Programm nebst Daten hier nicht installiert sind.

    Erst einmal herzlichen Dank für eure Mühe.
    Liebe Grüße Peter
  • Thabo-Umasai schrieb:

    Dann kann ich nur sagen gib mal die ganzen nicht gebrauchten Buttons raus und dann wird es auch funktionieren. Die werden sich sicher irgendwo überschneiden.
    Ich denke ich habe Deinen Fehler gefunden Da dies ja eigenständige Buttons sind solltest Du die von WsX5 transparent machen, somit solltest Du diesen auch verlieren.

    Thabo-Umasai schrieb:

    Ich denke ich habe Deinen Fehler gefunden Da dies ja eigenständige Buttons sind solltest Du die von WsX5 transparent machen, somit solltest Du diesen auch verlieren.

    Welche Buttons von WsX5 meinst du? Es werden nur eigene Butons verwendet...
    Liebe Grüße Peter
  • Und genau das ist dein Problem. Wenn du eigene Buttons benutzt und dort schon einen Namen einträgst dann wird der Name auch angezeigt...benennst du deine Seite bzw. Ebenen mit Namen wird dieser Namen in den Button geschrieben und du hast ihn zweimal. Mir war es erst nicht aufgefallen da X5 die Namen auch in die Bilder schreibt.
    :hi: :mario:
  • Dann kann ich Dir nur noch einen Tipp geben, mach diese eine Seite nicht sichtbar und dann funktioniert es. Beschreibe sie Produkte, jedoch dann als nicht sichtbar machen, und schon ist die weiße Schrift weg. Und Du hast Deinen gewünschten Erfolg. Das ist Deine Prob.
    Lg.
    Thabo-Umasai
    -----------------------------------------------------------------------------------------------------------
    "Was du heute kannst besorgen, das verschiebe nicht auf Morgen...."
    ;)
  • Sry, verstehe ich nicht. Die Seite Projekte ist nicht sichtbar gestellt. Die Ebene Pojekte ist sichtbar und hat keinen Menüpunkt zum nicht sichbar stellen, lediglich "auf link verweisen und Icon einstellen". Ich benötige jedoch ein Untermenü für die 16 Produkte nebst Bildern und Beschreibungen. Auf Link verweisen habe ich die nicht sichtbare Seite projekte.html gewählt, da diese den Einleitungstext enthält.

    Nun verstehe ich gar nichts mehr aber ich bin ja auch schon 62 Jahre.....
    Liebe Grüße Peter
  • Man kann kaum etwas in deinem Header erkennen...die Buttons haben unten einen Rand...die Schrift ist nicht gut gewählt...so alt bin ich noch nicht aber eigentlich solltest du das noch sehen ;)

    Also zu deiner Lösung....

    Du hast eine Ebene diese ist sichtbar.
    Diese Ebene hat unter Eigenschaften der Ebene einen Link zur unsichtbaren Inhaltsverzeichnis Seite diese Seite ist unsichtbar!
    Die restlichen Seiten sind sichtbar.
    Die Ebene hat KEINEN Namen!!! und unter Eigenschaften der Ebene hast du ein Icon vergeben welches im Menü angezeigt werden soll.

    Unter Schritt 4 > Hauptmenü hast du alle Hintergründe auf transparent gestellt?

    Du kannst jeder Seite und jeder Ebene einen Button geben.

    Aber wozu? Du hast doch überall die gleichen Bilder im Menü...das kann man auch unter Schritt 4 einfügen im Hauptmenü und kann dann dort die Schrift für den Button wählen und braucht ihn nicht selbst einzufügen sondern lässt ihn vom Programm erstellen....hier hast du dann auch die Möglichkeit den Stil des Buttons zu verändern da man ein zweites Bild auswählen kann oder den Text verändern kann bei aktiven oder mouseover Button.
    :hi: :mario:
  • Hi admin,

    danke für deine ausführliche Analyse.

    Mein Header enthält keine Daten und ist transparent. Mein Schwager WILL seine Hintergrundbilder und eigenen Buttons, also muss ich tricksen...Die Buttons habe ich als Mouseover mt einem blauen Unterstrich (hover) versehen. Die unterschiedlichen Hintergrundbilder (Kugel, Fische, Tropfen usw.) sollen nach Vorgabe eingesetzt werden. Des Menschen Wille ist sein Himmelreich....

    Werde mich morgen nochmals intensiv an die Aufbereitung setzen und deine Lösung versuchen zu integrieren.

    Für heute herzlichen Dank.
    Liebe Grüße Peter
  • Jetzt hab ich es erst gesehen...

    Wenn du willst kannst du mir mal per Email dein Projekt schicken da guck ich mir das mal direkt an. Das ist immer aus der Ferne schwer zu sagen und man muss raten. Meine Email Adresse steht im Impressum ansonsten kannst du mir auch eine PN (Private Nachricht) schreiben und dort das Projekt als Anhang einfügen wenn es nicht so groß ist.
    :hi: :mario:
  • So nun zum Problem...

    in der menu.css wird ein Bild ohne Dateinamen aufgerufen. 1und1 kann das nicht [img]wcf/images/smilies/angry.gif[/img]

    Abhilfe schafft hier ein kleiner Trick....

    CSS-Quellcode

    1. <style type="text/css">#imMnMn > ul > li#imMnMnNode30{background-image:url('../menu/produkte.png');height:62px;width:116px;}
    2. </style>


    Das kommt in den Head unter Schritt 1. Das Bild welches derzeit nicht geladen werden kann also .png benennst du per FTP Client oder direkt unter Schritt 5 um (oben habe ich es produkte.png genannt) ...ich hoffe du weißt was ich meine.
    :hi: :mario: